Dorkiphus.net

Dorkiphus.net (https://dorkiphus.net/porsche/index.php)
-   BMW Technical Discussions (https://dorkiphus.net/porsche/forumdisplay.php?f=96)
-   -   e39 528i help (https://dorkiphus.net/porsche/showthread.php?t=40826)

Uncle ENzo 11-20-2020 11:25 PM

e39 528i help
 
So I am in the throws of fixing up a 2000 528i 5speed I picked up for 500$. Body and interior were mint so I thought why not? Thus far I have replaced the clutch and rebuilt the vanos and suspension. So when I got the car the brakes were hard as a rock and I discovered the booster didnt hold a lick of vacuum. With that I put in a used working unit. Now comes the issue. When I bench bled the master I got good flow from the rear circuit but not the front two but didnt put too much stock into it. I have a spare master that is just as old that acted the same. I put it all back together and cant for the life of me get the front to spew any fluid at all when trying to bleed. Im thinking I have two worn out masters but wanted to see if you guys had any advice.

Thanks!

cmartin 11-21-2020 12:07 AM

No fluid when bench bleeding or when in the car? I havent seen one that didnt squirt fluid in the vise. If on the car its possible you have a bench or collapse line. Disco the line from the caliper to check for fluid there, similar upstream if there is a union.

btw, pretty sure a new master is $50, 10% of the car! :)

Uncle ENzo 11-21-2020 11:07 AM

Quote:

Originally Posted by cmartin (Post 642548)
No fluid when bench bleeding or when in the car? I havent seen one that didnt squirt fluid in the vise. If on the car its possible you have a bench or collapse line. Disco the line from the caliper to check for fluid there, similar upstream if there is a union.

btw, pretty sure a new master is $50, 10% of the car! :)

Actually on the bench. Got very little flow compared to others Iíve done in the past.

Uncle ENzo 11-21-2020 10:34 PM

At this point I’ve narrowed it down to a clogged valve in the unserviceable abs pump.

86911TLCAB 11-23-2020 09:13 AM

Not sure any help but my 99. 328is has full break system intact. If parts are the Same you can pull off what you need.

Uncle ENzo 11-23-2020 10:22 AM

Quote:

Originally Posted by 86911TLCAB (Post 642645)
Not sure any help but my 99. 328is has full break system intact. If parts are the Same you can pull off what you need.

Wow, thank you so much. I picked up an ABS pump on eBay last night so ill see if its any good. If not, I am going to reach out!

86911TLCAB 11-23-2020 12:04 PM

Pls let me know soon. Am pushing to get this car out of here soonest. I can pull it off if you think you want it and anything else..

Uncle ENzo 11-23-2020 12:43 PM

Quote:

Originally Posted by 86911TLCAB (Post 642661)
Pls let me know soon. Am pushing to get this car out of here soonest. I can pull it off if you think you want it and anything else..

Thank you! Ill have the used unit by week's end. If you get a sec, take look at the part number on the top of the pump and see if it reads 265.225.005

86911TLCAB 11-23-2020 12:45 PM

Ok. Will let you know.

86911TLCAB 11-23-2020 07:41 PM

It is different


All times are GMT -4. The time now is 04:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.